Google.WebAnalytics not working... any working examples?

Jul 2, 2010 at 1:48 PM

Hello,

I am using MSAF with Google Analytics behavior hooked to LayoutRoot (as well as service oriented silverytics behavior) and a bunch of TrackAction behaviors. The problem is that Silverytics aggregates all my events well, google however does not... I used silverlight spy to see if visual tree has image control used by Google's behavior and its url is defined properly (ie. a google analytics http address) and it is there... but still no events show up in google analytics panel. Firebug reports no activity regarding google analytics (no image downloads from google's domain). I have configured my google analytics Web ID, but didnt set any categories or application scope. Could you help me on this problem? Do you have a working example?

Jul 8, 2010 at 2:24 PM

It seems that it is caused by the fact that my application works over HTTPS protocol... Anyone could shed some light on this issue? :)

Jul 8, 2010 at 2:47 PM

Cross-scheme access (https->http) is not allowed using Image Silverlght control, this very likely means that Google Analytics behavior won't work with HTTPS silverlight applications... but please correct me if I am wrong.

Coordinator
Jul 8, 2010 at 3:54 PM

That's exactly it - an https page cannot access http content without direct user interaction.

Dec 9, 2010 at 3:01 AM

Wait... please tell me I am reading this wrong.

A SL4 app served via https cannot write events using MSAF?

??